kwk added a comment. @labath I've improved my test file for readability.
================ Comment at: lldb/include/lldb/Host/DebugInfoD.h:26 + +llvm::Error findSource(UUID buildID, const std::string &path, + std::string &result_path); ---------------- labath wrote: > Expected<string> ? Removed. ================ Comment at: lldb/include/lldb/Host/DebugInfoD.h:16-18 +namespace llvm { +class Error; +} // End of namespace llvm ---------------- labath wrote: > I guess this is not needed now. Right. ================ Comment at: lldb/packages/Python/lldbsuite/test/httpserver.py:75 + # Block only for 0.5 seconds max + httpd.timeout = 0.5 + # Allow for reusing the address ---------------- labath wrote: > What exactly is this timeout for? It seems rather small... uff, I guess I had an idea when I wrote it but its lost now. ================ Comment at: lldb/packages/Python/lldbsuite/test/lldbtest.py:4 -The concrete subclass can override lldbtest.TesBase in order to inherit the +The concrete subclass can override lldbtest.TestBase in order to inherit the common behavior for unitest.TestCase.setUp/tearDown implemented in this file. ---------------- labath wrote: > just commit this separately. no review needed. Done in 44361782e2c252c8886cd77f6b7d4ebe64fb6e8d. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D75750/new/ https://reviews.llvm.org/D75750 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits