friss added inline comments.
================ Comment at: packages/Python/lldbsuite/test/functionalities/data-formatter/data-formatter-stl/libcxx/function/TestLibCxxFunction.py:49-59 + self.runCmd("log timers reset") + self.expect("frame variable foo2_f", + substrs=['foo2_f = Lambda in File main.cpp at Line 30']) + self.expect("log timers dump", + substrs=['lldb_private::Module::FindSymbolsMatchingRegExAndType']) + + self.runCmd("log timers reset") ---------------- Can you wrap all of the above in a helper function? You repeat this same pattern for every variable, the test would be much more readable. It also gives you a good spot to expand a little bit on way the testing involves "timers". CHANGES SINCE LAST ACTION https://reviews.llvm.org/D67111/new/ https://reviews.llvm.org/D67111 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits