compnerd added inline comments.
================ Comment at: source/Plugins/Process/Utility/RegisterContextWindows_i386.cpp:40 + +// clang-format off +#define DEFINE_GPR(reg, alt, kind1, kind2, kind3, kind4) \ ---------------- I believe that this bounds the range, and needs to be re-enabled. Why not permit clang-format to reflow `DEFINE_GPR`? ================ Comment at: source/Plugins/Process/Utility/RegisterContextWindows_i386.cpp:76 + default: + assert(false && "Unhandled target architecture."); + return nullptr; ---------------- Could you use `llvm_unreachable` instead please? Same throughout. ================ Comment at: source/Plugins/Process/Utility/RegisterContextWindows_i386.cpp:84 + case llvm::Triple::x86: + return static_cast<uint32_t>(sizeof(g_register_infos_i386) / + sizeof(g_register_infos_i386[0])); ---------------- Why not `llvm::array_lengthof`? ================ Comment at: source/Plugins/Process/Utility/RegisterContextWindows_wow64.h:14 + +class RegisterContextWindows_wow64 + : public lldb_private::RegisterInfoInterface { ---------------- Could you spell this `WoW64` to match the Microsoft naming scheme for the "proper" noun? Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D63165/new/ https://reviews.llvm.org/D63165 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits