clayborg added a comment.

I don't see much I would change here as long as this works and gets tested by 
the generic GDB remote protocol testing? Any others have comments?



================
Comment at: source/Plugins/Process/Windows/Common/DebuggerThread.cpp:350
+        (info.ExceptionRecord.ExceptionCode == EXCEPTION_BREAKPOINT ||
+         info.ExceptionRecord.ExceptionCode == 0x4000001FL /* WOW64 
STATUS_WX86_BREAKPOINT */)) {
       LLDB_LOG(log, "Breakpoint exception is cue to detach from process {0:x}",
----------------
Define STATUS_WX86_BREAKPOINT somewhere and don't use a magic number?


Repository:
  rLLDB LLDB

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D63165/new/

https://reviews.llvm.org/D63165



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to