JDevlieghere accepted this revision. JDevlieghere added inline comments. This revision is now accepted and ready to land.
================ Comment at: source/Plugins/SymbolFile/DWARF/SymbolFileDWARF.h:303 + lldb_private::FileSpec GetSupportFile(DWARFUnit &unit, size_t file_idx); + ---------------- labath wrote: > JDevlieghere wrote: > > clayborg wrote: > > > Can probably just be named GetFile > > Should this return an optional? > I don't know. On one hand, both the level above this function and the level > below use an empty FileSpec do denote failure, so I'd have to convert it > explicitly in both places. OTOH, Optional is the direction we want to move in. > > I can change it if you want.. Yeah it's a bit of a chicken & egg problem. I don't have a strong opinion, so I'm fine with keeping it as is. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D62894/new/ https://reviews.llvm.org/D62894 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits