balazske added inline comments.
================ Comment at: lldb/include/lldb/Symbol/ClangASTImporter.h:249 + /// it at the end of the scope. Supports being used multiple times on the + /// same Minion instance in nested scopes. + class CxxModuleScope { ---------------- teemperor wrote: > aprantl wrote: > > teemperor wrote: > > > aprantl wrote: > > > > I really wish we could rename Minion with something actually > > > > descriptive... > > > I'm still trying to come up with a good name. The whole purpose of the > > > class is to actually extend and listen to the actual ASTImporter. So what > > > about `ASTImporterDecorator`? > > ASTImporterDelegate perhaps? > > https://en.wikipedia.org/wiki/Delegation_pattern > Sounds good to me, even though we technically inherit from ASTImporter. But > everything is better than Minion :) Yes `Minion` is not a good name. But `Delegate` in general is not much better (it may be called `ASTImporterSubclass` in this manner), it does not tell anything about what is does. Repository: rL LLVM CHANGES SINCE LAST ACTION https://reviews.llvm.org/D59537/new/ https://reviews.llvm.org/D59537 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits