shafik accepted this revision. shafik added a comment. This is a good change!
================ Comment at: lldb/include/lldb/Symbol/ClangASTImporter.h:259 public: - CxxModuleScope(Minion &minion, clang::ASTContext *dst_ctx) + CxxModuleScope(ASTImporterDelegate &minion, clang::ASTContext *dst_ctx) : m_minion(minion) { ---------------- martong wrote: > The name of the parameter is still `minion` ... if the goal is to completely > wipe out the old name then perhaps these should be renamed. Also with the new > type name it just feels odd. I fee like `importer_delegate` makes more sense now. ================ Comment at: lldb/include/lldb/Symbol/ClangASTImporter.h:328 clang::ASTContext *m_dst_ctx; - MinionMap m_minions; + DelegateMap m_minions; OriginMap m_origins; ---------------- martong wrote: > Would it make sense to rename the variables too? E.g. `m_delegates`? or `m_importer_delegates` Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D61299/new/ https://reviews.llvm.org/D61299 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits