labath added inline comments.
================ Comment at: include/lldb/Utility/Args.h:121 + bool GetFlattenWindowsCommandString(std::string &command) const; + ---------------- I am sorry for being such a pain, but I don't think this is grammatically correct, as `get` and `flatten` are both verbs. I'd call this either GetFlatten**ed**WindowsCommandLine or just plain FlattenWindowsCommandLine. ================ Comment at: source/Utility/Args.cpp:252 + + command = llvm::sys::flattenWindowsCommandLine(args); + return true; ---------------- This will not compile on non-windows systems as `flattenWindowsCommandLine` is `#ifdef _WIN32`. We can either try removing the ifdefs from the llvm function, or put this code somewhere under `Host/windows` (it could just be a static function in ProcessLauncherWindows). CHANGES SINCE LAST ACTION https://reviews.llvm.org/D56230/new/ https://reviews.llvm.org/D56230 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits