grimar added a comment.

Thanks for all the comments!

In https://reviews.llvm.org/D52403#1243127, @clayborg wrote:

> So the main questions is: do we need a new section enum called 
> eSectionTypeDWARFDebugInfoDWO? If so, then this patch changes. I think I 
> would prefer adding a new enum.


Yeah, that is what I thought at the first place too. I found that when code 
looks for some section, it seems sometimes assumes it can find .dwo section by 
regular section enum value.
I thought that time that much more changes might be required (for example, 
introducing enum values for each .dwo section and perhaps fixing callers)
and so selected the simplest solution (this patch), because original code 
already used filtering by section name "dwo" suffix.

I'll try to investigate it again, want to check a few ideas I have in mind.


https://reviews.llvm.org/D52403



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to