aprantl added inline comments.

================
Comment at: source/Plugins/Process/Utility/RegisterContextDarwinConstants.h:18
+  KERNEL_SUCCESS = 0,
+  KERNEL_INVALID_ARGUMENT = 4,
+};
----------------
I think I would prefer

#ifndef KERN_INVALID_ARGUMENT
#define KERN_INVALID_ARGUMENT 4
#endif

over renaming the constant. I think that that is less confusing to read and we 
use that pattern in other places in LLDB, too.


https://reviews.llvm.org/D46934



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to