zturner added a comment. In https://reviews.llvm.org/D30789#696870, @jingham wrote:
> What is the motivation behind of the "2" versions of the functions you added? Ahh yea. I can call them something else if you have a better name. But basically in a unit test I don't have an instance of a `CommandInterpreter` object, and creating one is non-trivial (it requires a `Debugger` instance, which requires calling `Debugger::CreateInstance()`, which depends on a lot of other system initialization having been done. But none of the methods I was trying to test use the `CommandInterpreter` anyway, so I just needed some kind of interface into the completion that didn't require me to pass one in. https://reviews.llvm.org/D30789 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits