On Mon, Sep 08, 2008 at 02:09:53PM -0500, Becky Bruce wrote: > +/* We support DMA to/from any memory page via the iommu */ > +static int dma_iommu_dma_supported(struct device *dev, u64 mask) > +{ > + struct iommu_table *tbl = dev->archdata.dma_data; > + > + if (!tbl || tbl->it_offset > mask) { > + printk(KERN_INFO > + "Warning: IOMMU offset too big for device mask\n"); > + if (tbl) > + printk(KERN_INFO > + "mask: 0x%08lx, table offset: 0x%08lx\n", > + mask, tbl->it_offset); > + else > + printk(KERN_INFO "mask: 0x%08lx, table unavailable\n", > + mask); > + return 0; > + } else > + return 1; > +}
Small nitpick, but wouldn't a if (tbl && tbl->it_offset <= mask) return 1; < the rest> be much easier to read? _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org https://ozlabs.org/mailman/listinfo/linuxppc-dev