On 03/18, Sudeep Holla wrote: > > On Mon, Mar 18, 2019 at 06:33:41PM +0100, Oleg Nesterov wrote: > > On 03/18, Sudeep Holla wrote: > > > > > > On Mon, Mar 18, 2019 at 06:20:24PM +0100, Oleg Nesterov wrote: > > > > > > > > Again, to me this patch just makes the code look worse. Honestly, I > > > > don't > > > > think that the new (badly named) ptrace_syscall_enter() hook makes any > > > > sense. > > > > > > > > > > Worse because we end up reading current_thread_info->flags twice ? > > > > Mostly because in my opinion ptrace_syscall_enter() buys nothing but makes > > the caller's code less readable/understandable. > > > > Sure, this is subjective. > > > > Based on what we have in that function today, I tend to agree. Will and > Richard were in the opinion to consolidate SYSEMU handling
Well, personally I see no point... Again, after the trivial simplification x86 does if (work & (_TIF_SYSCALL_EMU | _TIF_SYSCALL_TRACE)) { ret = tracehook_report_syscall_entry(regs); if (ret || (work & _TIF_SYSCALL_EMU)) return -1L; } this looks simple enough for copy-and-paste. > If there's a better way to achieve the same I can only say that if we add a common helper, I think it should absorb tracehook_report_syscall_entry() and handle both TIF's just like the code above does. Not sure this makes any sense. Oleg.