On Tue, Dec 04, 2007 at 08:06:25PM +0300, Anton Vorontsov wrote: > Split pata_platform_{probe,remove} into two pieces: > 1. pata_platform_{probe,remove} -- platform_device-dependant bits; > 2. __ptata_platform_{probe,remove} -- device type neutral bits. > > This is done to not duplicate code for the OF-platform driver.
Paul, do you have any objections regarding that one? If there is no objections, could you stamp Acked-by on it? Thus I can resend this set one more time for the merge, w/o fourth patch. > /** > - * pata_platform_probe - attach a platform interface > - * @pdev: platform device > + * __pata_platform_probe - attach a platform interface > + * @dev: device > + * @io_res: Resource representing I/O base > + * @ctl_res: Resource representing CTL base > + * @irq_res: Resource representing IRQ and its flags > + * @ioport_shift: I/O port shift + * @__pio_mask: PIO mask ^^^ added Thanks, -- Anton Vorontsov email: [EMAIL PROTECTED] backup email: [EMAIL PROTECTED] irc://irc.freenode.net/bd2 _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org https://ozlabs.org/mailman/listinfo/linuxppc-dev