On Tue, Jun 30, 2026 at 05:28:20PM +0100, Pedro Falcato wrote: > On Mon, Jun 29, 2026 at 01:23:19PM +0100, Lorenzo Stoakes wrote: > > The family of vma_interval_tree_() functions manipulate the > > address_space (which, of course, is generally referred to as 'mapping') > > reverse mapping, but are named the 'VMA' interval tree. > > > > VMAs may be mapped by an anon_vma, an address_space, or both. Therefore > > calling the mapping interval tree a 'VMA' interval tree is rather > > confusing. > > > > This is also inconsistent with the anon_vma_interval_tree_*() functions > > which explicitly reference the rmap object to which they pertain. > > > > Rename the vma_interval_tree_*() functions to mapping_interval_tree_*() to > > correct this. > > > > No functional change intended. > > > > Signed-off-by: Lorenzo Stoakes <[email protected]> > > I'll have to nitpick this and say that I prefer [1] file_rmap_tree_, or > mapping_rmap_tree. Or possibly even better - mapping_ (so > mapping_for_each_vma, mapping_insert_vma, etc).
Haha of course. I don't like mapping_ because that is such an overloaded term and it's confusing really. I'm iffy on mapping_rmap_tree as it feels like that implies 'this is the whole of how the rmap lookup works', and it also makes it less obvious what _kind_ of tree it is, though I suppose you could look up the types, but the crap macro generation makes that more of a pain. Also, for file 'rmap' you are potentially not actually doing an rmap at all in the classical sense of folio -> rmap object -> related VMAs, but rather are going from file/inode -> <page cache abstraction> -> related VMAs... But then again a quick spot check suggests it's usually from a folio... I guess only the rmap really needs to find the VMAs. Also if I renamed it to mapping_rmap_tree I'd have to respin and churn all the anon_vma code but I guess that's not impossible... :) I guess I'm a bit stubborn about doing much with the anon_vma stuff until I get rid of it. But I couldn't live with the stupidity of calling it vma_interval_tree_*() anymore here... OK I'm a bit torn, mapping_rmap_tree*() and anon_rmap_tree*() are the workable contenders from your suggestions. Let me think about that on respin... :) > > A bit of bikeshedding never hurts ;) > > [1] locally I was naming things file_rmap, but I never actually got to > churn these names away > -- > Pedro Cheers, Lorenzo
