Messages by Thread
-
[PATCH v7 00/10] tracing: wprobe: x86: Add wprobe for watchpoint
Masami Hiramatsu (Google)
-
[PATCH v5 0/5] Enable perf tracing for unprivileged users
Anubhav Shelat
-
[PATCH v5 1/5] eventfs: define event fields before directory creation
Anubhav Shelat
-
[PATCH v5 2/5] tracefs: add read-only eventfs filesystem at /sys/kernel/events
Anubhav Shelat
-
[PATCH v5 5/5] perf: enable unprivileged syscall tracing with perf trace
Anubhav Shelat
-
[RFC PATCH 00/13] mm/kwatch: dynamic hardware watchpoints for hunting memory corruption
Jinchao Wang
-
Re: [PATCH v3 4/5] sched: Add task enqueue/dequeue trace points
Steven Rostedt
-
Re: [PATCH] selftests/ftrace: Add test case for a symbol in a module without module name
Steven Rostedt
-
Re: [PATCH] bpf/btf: Move tracing BTF APIs to the BTF library
Steven Rostedt
-
[PATCH] rv: Simplify task monitor slot management
liqiang
-
[PATCH v6 3/9] mm: use enum migrate_reason instead of int for migration reason parameters
Ye Liu
-
[PATCH v6 2/9] mm/page_owner: add MR_NEVER to enum migrate_reason and use it for last_migrate_reason
Ye Liu
-
[PATCH v3 0/5] tracing/probes: Clean up and refactor argument parser
Masami Hiramatsu (Google)
-
[PATCH] rtla/timerlat_top: Fix on-threshold actions firing on signal
Tomas Glozar
-
[PATCH] tracing: Add mutex to trace_parser to fix concurrent write races
Tengda Wu
-
[PATCH v1] tracing/remotes: Fix page_va[] access before counter update in trace_remote_alloc_buffer()
Fuad Tabba
-
[PATCH v4] tracing: Use seq_buf for string concatenation
Woradorn Laodhanadhaworn
-
[PATCH] tracing: Defer trigger private data frees past the grace period
David Carlier
-
[PATCH 0/5] tracing/probes: Clean up and refactor argument parser
Masami Hiramatsu (Google)
-
[PATCH v3 0/5] tracing: add ref_trace_final_put tracing
Eugene Mavick
-
[PATCH v2 00/33] mm: make VMA page offset handling more consistent
Lorenzo Stoakes
-
[PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Lorenzo Stoakes
-
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Liam R. Howlett
-
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Lorenzo Stoakes (ARM)
-
Re: [PATCH v2 01/33] mm: move vma_start_pgoff() into mm.h and clean up
Zi Yan
-
[PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Lorenzo Stoakes
-
Re: [PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Liam R. Howlett
-
Re: [PATCH v2 02/33] mm: add kdoc comments for vma_start/last_pgoff()
Zi Yan
-
[PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Lorenzo Stoakes
-
Re: [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Liam R. Howlett
-
Re: [PATCH v2 03/33] tools/testing/vma: use vma_start_pgoff() in merge tests
Zi Yan
-
[PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Lorenzo Stoakes
-
Re: [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 05/33] mm/rmap: update mm/interval_tree.c comments
Zi Yan
-
[PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Lorenzo Stoakes
-
Re: [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 06/33] mm/rmap: parameterise vma_interval_tree_*() by address_space
Zi Yan
-
[PATCH v2 04/33] mm: introduce and use vma_end_pgoff()
Lorenzo Stoakes
-
Re: [PATCH v2 04/33] mm: introduce and use vma_end_pgoff()
Zi Yan
-
[PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Lorenzo Stoakes
-
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Zi Yan
-
Re: [PATCH v2 08/33] mm/rmap: rename vma_interval_tree_*() to mapping_rmap_tree_*()
Lorenzo Stoakes (ARM)
-
[PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Lorenzo Stoakes
-
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Gregory Price
-
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 09/33] mm/rmap: parameterise anon_vma_interval_tree_*() by anon_vma
Zi Yan
-
[PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Lorenzo Stoakes
-
Re: [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 07/33] mm/rmap: elide unnecessary static inline's in interval_tree.c
Zi Yan
-
[PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Lorenzo Stoakes
-
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Gregory Price
-
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 10/33] mm/rmap: rename anon_vma_interval_tree_*() params and use pgoff_t
Zi Yan
-
[PATCH v2 15/33] mm/vma: refactor vmg_adjust_set_range() for clarity
Lorenzo Stoakes
-
Re: [PATCH v2 15/33] mm/vma: refactor vmg_adjust_set_range() for clarity
Vlastimil Babka (SUSE)
-
[PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Lorenzo Stoakes
-
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Gregory Price
-
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 11/33] mm/rmap: rename anon_vma_interval_tree_*() to anon_rmap_tree_*()
Zi Yan
-
[PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Lorenzo Stoakes
-
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 13/33] mm/vma: introduce and use vmg_pages(), vmg_[start, end]_pgoff()
Lorenzo Stoakes (ARM)
-
[PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Lorenzo Stoakes
-
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Zi Yan
-
Re: [PATCH v2 12/33] MAINTAINERS: Move mm/interval_tree.c to rmap section
Liam R. Howlett
-
[PATCH v2 20/33] mm/vma: remove duplicative vma_pgoff_offset() helper
Lorenzo Stoakes
-
Re: [PATCH v2 20/33] mm/vma: remove duplicative vma_pgoff_offset() helper
Vlastimil Babka (SUSE)
-
[PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
Lorenzo Stoakes
-
Re: [PATCH v2 14/33] mm/vma: clean up anon_vma_compatible()
Vlastimil Babka (SUSE)
-
[PATCH v2 16/33] mm/vma: minor cleanup of expand_[upwards, downwards]()
Lorenzo Stoakes
-
Re: [PATCH v2 16/33] mm/vma: minor cleanup of expand_[upwards, downwards]()
Vlastimil Babka (SUSE)
-
[PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Lorenzo Stoakes
-
Re: [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Gregory Price
-
Re: [PATCH v2 29/33] mm/vma: introduce and use vma_set_pgoff()
Vlastimil Babka (SUSE)
-
[PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Lorenzo Stoakes
-
Re: [PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Gregory Price
-
Re: [PATCH v2 22/33] mm/vma: introduce vma_assert_can_modify()
Vlastimil Babka (SUSE)
-
[PATCH v2 17/33] mm: introduce and use linear_page_delta()
Lorenzo Stoakes
-
Re: [PATCH v2 17/33] mm: introduce and use linear_page_delta()
Vlastimil Babka (SUSE)
-
[PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Lorenzo Stoakes
-
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Lorenzo Stoakes (ARM)
-
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 18/33] mm/vma: use vma_start_pgoff(), linear_page_index() in mm code
Lorenzo Stoakes (ARM)
-
[PATCH v2 19/33] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Lorenzo Stoakes
-
Re: [PATCH v2 19/33] mm: prefer vma_[start,end]_pgoff() to vma->vm_pgoff in kernel/
Vlastimil Babka (SUSE)
-
[PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Lorenzo Stoakes
-
Re: [PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Gregory Price
-
Re: [PATCH v2 26/33] mm/vma: update vma_shrink() to not pass start, pgoff parameters
Vlastimil Babka (SUSE)
-
[PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Lorenzo Stoakes
-
Re: [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 25/33] mm/vma: make vma_set_range() static, drop insert_vm_struct() decl
Lorenzo Stoakes (ARM)
-
[PATCH v2 21/33] mm: use linear_page_[index, delta]() consistently
Lorenzo Stoakes
-
Re: [PATCH v2 21/33] mm: use linear_page_[index, delta]() consistently
Vlastimil Babka (SUSE)
-
[PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Lorenzo Stoakes
-
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Gregory Price
-
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 23/33] mm/vma: add and use vma_[add/sub]_pgoff()
Lorenzo Stoakes (ARM)
-
[PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Lorenzo Stoakes
-
Re: [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Gregory Price
-
Re: [PATCH v2 28/33] mm/vma: slightly rework the anonymous check in __mmap_new_vma()
Vlastimil Babka (SUSE)
-
[PATCH v2 24/33] mm/vma: move __install_special_mapping() to vma.c
Lorenzo Stoakes
-
Re: [PATCH v2 24/33] mm/vma: move __install_special_mapping() to vma.c
Vlastimil Babka (SUSE)
-
[PATCH v2 27/33] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
Lorenzo Stoakes
-
Re: [PATCH v2 27/33] mm/vma: update vmg_adjust_set_range() to offset pgoff instead
Vlastimil Babka (SUSE)
-
[PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Lorenzo Stoakes
-
Re: [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Vlastimil Babka (SUSE)
-
Re: [PATCH v2 30/33] mm/vma: correct incorrect vma.h inclusion
Lorenzo Stoakes (ARM)
-
[PATCH v2 31/33] mm/vma: use guard clauses in can_vma_merge_[before, after]()
Lorenzo Stoakes
-
Re: [PATCH v2 31/33] mm/vma: use guard clauses in can_vma_merge_[before, after]()
Vlastimil Babka (SUSE)
-
[PATCH v2 33/33] tools/testing/vma: output compared expression on ASSERT_[EQ, NE]()
Lorenzo Stoakes
-
[PATCH v2 32/33] tools/testing/vma: default VMA, mm flag bits to 64-bit
Lorenzo Stoakes
-
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Andrew Morton
-
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Lorenzo Stoakes
-
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Christian König
-
Re: [PATCH v2 00/33] mm: make VMA page offset handling more consistent
Lorenzo Stoakes (ARM)
-
[PATCH v2 0/2] Add trace event support for GENI SE registers dump
Praveen Talari