Hi, On Fri, Jul 24, 2015 at 02:39:12PM +0200, Frans Klaver wrote: > On Fri, Jul 24, 2015 at 2:26 PM, Sebastian Reichel <s...@kernel.org> wrote: > > On Fri, Jul 24, 2015 at 05:28:13PM +0530, Vaishali Thakkar wrote: > >> Use devm_kasprintf instead of kasprintf. Also, remove various > >> gotos by direct returns and drop unneeded label err_free_name. > > > > Please also use devm_power_supply_unregister() instead > > of power_supply_unregister() to further simplify the driver. > > Sounds like a separate patch.
I would be fine with either one or two patches. It's common, that devm conversion happens in one commit instead of one patch per function change. -- Sebastian
signature.asc
Description: Digital signature