On Mon, Apr 27, 2015 at 09:39:05AM +0200, Michael Wang wrote: > > > On 04/24/2015 05:12 PM, Liran Liss wrote: > >> From: linux-rdma-ow...@vger.kernel.org [mailto:linux-rdma- > >> > > [snip] > >> a/include/rdma/ib_verbs.h b/include/rdma/ib_verbs.h index > >> 65994a1..d54f91e 100644 > >> --- a/include/rdma/ib_verbs.h > >> +++ b/include/rdma/ib_verbs.h > >> @@ -75,10 +75,13 @@ enum rdma_node_type { }; > >> > >> enum rdma_transport_type { > >> + /* legacy for users */ > >> RDMA_TRANSPORT_IB, > >> RDMA_TRANSPORT_IWARP, > >> RDMA_TRANSPORT_USNIC, > >> - RDMA_TRANSPORT_USNIC_UDP > >> + RDMA_TRANSPORT_USNIC_UDP, > >> + /* new transport */ > >> + RDMA_TRANSPORT_IBOE, > > > > Remove RDMA_TRANSPORT_IBOE - it is not a transport. > > ROCE uses IBTA transport. > > > > If any code should test for ROCE should invoke a specific helper, e.g., > > rdma_protocol_iboe(). > > This is what you currently call "rdma_tech_iboe" is patch 02/26. > > > > I think that pretty much everybody agrees that rdma_protocol_*() is a > > better name than rdma_tech_*(), right? > > So, let's change this. > > Sure, sounds reasonable now, about the IBOE, we still need it to > separate the port support IB/ETH without the check on link-layer, > So what about a new enum on protocol type? > > Like: > > enum rdma_protocol { > RDMA_PROTOCOL_IB, > RDMA_PROTOCOL_IBOE, > RDMA_PROTOCOL_IWARP, > RDMA_PROTOCOL_USNIC_UDP > }; > > So we could use query_protocol() to ask device provide the protocol > type, and there will be no mixing with the legacy transport type > anymore :-)
I'm ok with that. I like introducing a unique namespace which is clearly different from the previous "transport" one. Ira -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/