On Friday, January 30, 2015 07:07:14 AM Xue, Ken wrote:
> Hi Rafael,
>       I looked into your patch in https://patchwork.kernel.org/patch/5677461/.
>       I found that "XXX_platform_notify" should be implemented separately  in 
> LPSS and APD driver  instead of "acpi_soc_platform_notify" in acpi_soc.
>       Because there is WA can't be share with two drivers. And it can make 
> LPSS or APD driver more flexible.
> 
>       Then only "acpi_soc_create_device" can be shared by LPSS and APD. 
> Maybe, the meaning of acpi_soc becomes less than what we expected.
>       So, can we go back to two separated drivers without any binding?

I don't want code duplication between them, though.  So if there's a function
that may be shared between them, it should be shared.  And so on.  No duplicate
data structure definitions etc.

> And try thoughts about acpi_soc, if there were more common features.

As I said.  If you can do that without code duplication, please feel free to 
try.


-- 
I speak only for myself.
Rafael J. Wysocki, Intel Open Source Technology Center.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to