Hi Michal,


On Fri, 02 Jan 2015 17:04:42 +0100
Michal Marek <mma...@suse.cz> wrote:

> >  
> > -quiet_cmd_bounds = GEN     $@
> > -define cmd_bounds
> > +quiet_cmd_offsets = GEN     $@
> > +define cmd_offsets
> >     (set -e; \
> > -    echo "#ifndef __LINUX_BOUNDS_H__"; \
> > -    echo "#define __LINUX_BOUNDS_H__"; \
> > +    INCLUDE_GUARD=$$(echo __$(notdir $@)__ | tr '[a-z].-' '[A-Z]__'); \
> > +    echo "#ifndef $$INCLUDE_GUARD"; \
> > +    echo "#define $$INCLUDE_GUARD"; \
> 
> I think it would be more readable to write it as
> 
>   echo "#ifndef $(2)"; \
>   ...
> 
> and pass the include guard name as an argument to cmd_offsets.
> 
> Otherwise it's a great cleanup.
> 
> Michal


OK.  I have posted v2.


Best Regards
Masahiro Yamada

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to