On 3 December 2014 at 11:37, Pravin Shelar <pshe...@nicira.com> wrote:
> On Tue, Dec 2, 2014 at 6:56 PM, Joe Stringer <joestrin...@nicira.com> wrote:
>> diff --git a/net/openvswitch/datapath.c b/net/openvswitch/datapath.c
>> index 332b5a0..b2a3796 100644
>> --- a/net/openvswitch/datapath.c
>> +++ b/net/openvswitch/datapath.c
>> @@ -462,10 +462,8 @@ static int queue_userspace_packet(struct datapath *dp, 
>> struct sk_buff *skb,
>>                              0, upcall_info->cmd);
>>         upcall->dp_ifindex = dp_ifindex;
>>
>> -       nla = nla_nest_start(user_skb, OVS_PACKET_ATTR_KEY);
>> -       err = ovs_nla_put_flow(key, key, user_skb);
>> +       err = ovs_nla_put_flow(key, key, OVS_PACKET_ATTR_KEY, false, 
>> user_skb);
>
> We need different name here, since it does not operate on flow. maybe
> __ovs_nla_put_key(). we can move the function definition to
> flow_netlink.h

OK sure. I'll fix this up for the next version.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to