On Tue, Feb 18, 2014 at 03:53:40PM -0800, j...@joshtriplett.org wrote: > On Tue, Feb 18, 2014 at 01:31:47PM -0800, Paul E. McKenney wrote: > > On Mon, Feb 17, 2014 at 04:23:01PM -0800, Josh Triplett wrote: > > > On Mon, Feb 17, 2014 at 02:12:21PM -0800, Paul E. McKenney wrote: > > > > From: "Paul E. McKenney" <paul...@linux.vnet.ibm.com> > > > > > > > > Create a torture_param() macro and apply it to rcutorture in order to > > > > save a few lines of code. This same macro may be applied to other > > > > torture frameworks. > > > > > > > > Signed-off-by: Paul E. McKenney <paul...@linux.vnet.ibm.com> > > > > > > Your commit message says "torture_param", but your code says > > > "torture_parm". Let's go with the former, please; no need to creat more > > > disemvoweled abbreviations. > > > > Gd pnt, fxd s sggstd. > > Thnks! > > > > Also, this seems rather generally useful. A quick check with "git grep > > > -B2 MODULE_PARM_DESC" turns up numerous instances of the pattern. You > > > might consider adding this as a helper DECLARE_MODULE_PARAM_RO in > > > include/linux/moduleparam.h (possibly calling a generalized version that > > > takes the mode as another parameter). > > > > Added to the todo list. Another parameter is static vs. not -- I only > > had one non-static instance, which I left open-coded. > > I debated that one. You could leave out the "static" and just write > "static DECLARE_MODULE_PARAM_RO", but given that you almost always > *want* static for a module parameter...
Indeed, adding a storage-class argument for the benefit of only one parameter didn't seem to make sense. Thanx, Paul -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/