On Tue, Feb 11, 2014 at 7:59 PM, Dongsheng Yang <yangds.f...@cn.fujitsu.com> wrote: > Hi Kees, > > > On 02/12/2014 02:27 AM, Kees Cook wrote: >> >> On Mon, Feb 10, 2014 at 11:34 PM, Dongsheng Yang >> <yangds.f...@cn.fujitsu.com> wrote: >>> >>> Signed-off-by: Dongsheng Yang <yangds.f...@cn.fujitsu.com> >>> cc: Andrew Morton <a...@linux-foundation.org> >>> cc: Oleg Nesterov <o...@redhat.com> >>> cc: Robin Holt <h...@sgi.com> >>> cc: Al Viro <v...@zeniv.linux.org.uk> >>> cc: Kees Cook <keesc...@chromium.org> >>> cc: "Eric W. Biederman" <ebied...@xmission.com> >>> cc: Stephen Rothwell <s...@canb.auug.org.au> >>> cc: Peter Zijlstra <pet...@infradead.org> >>> cc: Ingo Molnar <mi...@kernel.org> >>> --- >>> kernel/sys.c | 8 ++++---- >>> 1 file changed, 4 insertions(+), 4 deletions(-) >>> >>> diff --git a/kernel/sys.c b/kernel/sys.c >>> index c0a58be..adaeab6 100644 >>> --- a/kernel/sys.c >>> +++ b/kernel/sys.c >>> @@ -174,10 +174,10 @@ SYSCALL_DEFINE3(setpriority, int, which, int, who, >>> int, niceval) >>> >>> /* normalize: avoid signed division (rounding problems) */ >>> error = -ESRCH; >>> - if (niceval < -20) >>> - niceval = -20; >>> - if (niceval > 19) >>> - niceval = 19; >>> + if (niceval < MIN_NICE) >>> + niceval = MIN_NICE; >>> + if (niceval > MAX_NICE) >>> + niceval = MAX_NICE; >> >> Good catch! I'm all for using names instead of numeric values, >> however, I wonder if it'd be more readable to use "clamp" instead? >> >> niceval = clamp(niceval, MIN_NICE, MAX_NICE); > > > Good suggestion! This patch here is just to replace the numeric values with > a name defined in prio.h. So I will send another patch to make it more > readable > with clamp after the patch set here applied. Is this plan ok to you?
Sounds good to me. Thanks! -Kees > > Thanx. > >> >> -Kees >> >>> rcu_read_lock(); >>> read_lock(&tasklist_lock); >>> -- >>> 1.8.2.1 >>> >> >> > -- Kees Cook Chrome OS Security -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/