Hi Arnd!

On 01/02/2014 01:07 PM, Arnd Bergmann wrote:
> interruptible_sleep_on is racy and going away. This replaces
> one use in the radio-cadet driver with an open-coded
> wait loop that lets us check the condition under the mutex
> but sleep without it.
> 
> Signed-off-by: Arnd Bergmann <a...@arndb.de>
> Cc: Hans Verkuil <hverk...@xs4all.nl>
> Cc: Mauro Carvalho Chehab <m.che...@samsung.com>
> Cc: linux-me...@vger.kernel.org
> ---
>  drivers/media/radio/radio-cadet.c | 12 ++++++++++--
>  1 file changed, 10 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/media/radio/radio-cadet.c 
> b/drivers/media/radio/radio-cadet.c
> index 545c04c..67b5bbf 100644
> --- a/drivers/media/radio/radio-cadet.c
> +++ b/drivers/media/radio/radio-cadet.c
> @@ -39,6 +39,7 @@
>  #include <linux/pnp.h>
>  #include <linux/sched.h>
>  #include <linux/io.h>                /* outb, outb_p                 */
> +#include <linux/wait.h>
>  #include <media/v4l2-device.h>
>  #include <media/v4l2-ioctl.h>
>  #include <media/v4l2-ctrls.h>
> @@ -323,25 +324,32 @@ static ssize_t cadet_read(struct file *file, char 
> __user *data, size_t count, lo
>       struct cadet *dev = video_drvdata(file);
>       unsigned char readbuf[RDS_BUFFER];
>       int i = 0;
> +     DEFINE_WAIT(wait);
>  
>       mutex_lock(&dev->lock);
>       if (dev->rdsstat == 0)
>               cadet_start_rds(dev);
> -     if (dev->rdsin == dev->rdsout) {
> +     while (1) {
> +             prepare_to_wait(&dev->read_queue, &wait, TASK_INTERRUPTIBLE);
> +             if (dev->rdsin != dev->rdsout)
> +                     break;
> +
>               if (file->f_flags & O_NONBLOCK) {
>                       i = -EWOULDBLOCK;
>                       goto unlock;
>               }
>               mutex_unlock(&dev->lock);
> -             interruptible_sleep_on(&dev->read_queue);
> +             schedule();
>               mutex_lock(&dev->lock);
>       }
> +

This seems overly complicated. Isn't it enough to replace interruptible_sleep_on
by 'wait_event_interruptible(&dev->read_queue, dev->rdsin != dev->rdsout);'?

Or am I missing something subtle?

Regards,

        Hans

>       while (i < count && dev->rdsin != dev->rdsout)
>               readbuf[i++] = dev->rdsbuf[dev->rdsout++];
>  
>       if (i && copy_to_user(data, readbuf, i))
>               i = -EFAULT;
>  unlock:
> +     finish_wait(&dev->read_queue, &wait);
>       mutex_unlock(&dev->lock);
>       return i;
>  }
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to