Patch 1 is for removing one division operation with multiplication. Patch 2,3 is for clean-up related to load_balance(), there is improvement in terms of code size and readability may be also improved.
Feel free to give a comment for this patchset. It's tested on v3.10. On v3.11-rc3, it can be compiled properly. * Change from v2 [2/3]: set initial value 1 to should_balance in rebalance_domains() as Vincent commented [3/3]: not overwrite sum_weighted_load to represent load_per_task. Instead, use newly load_per_task as Preeti commented * Change from v1 Remove 2 patches, because I'm not sure they are right. Joonsoo Kim (3): sched: remove one division operation in find_buiest_queue() sched: factor out code to should_we_balance() sched: clean-up struct sd_lb_stat kernel/sched/fair.c | 326 +++++++++++++++++++++++++-------------------------- 1 file changed, 162 insertions(+), 164 deletions(-) -- 1.7.9.5 -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/