On Tue, 2013-06-25 at 20:35 -0600, Bjorn Helgaas wrote: > On Tue, Jun 25, 2013 at 7:53 PM, Darren Hart <dvh...@linux.intel.com> wrote:
> > static DEFINE_PCI_DEVICE_TABLE(pch_gbe_pcidev_id) = { > > {.vendor = PCI_VENDOR_ID_INTEL, > > .device = PCI_DEVICE_ID_INTEL_IOH1_GBE, > > + .subvendor = PCI_VENDOR_ID_CIRCUITCO, > > + .subdevice = PCI_DEVICE_ID_CIRCUITCO_MINNOWBOARD, > > "MINNOWBOARD" seems like a pretty generic name for something that > probably refers only to the gigabit ethernet device in the EG20T. If > you expect to use that same subdevice ID on other devices, I guess we > can add PCI_DEVICE_ID_CIRCUITCO_MINNOWBOARD to pci_ids.h. If it will > only be used for the gigabit ethernet device, we would normally not > add a #define for it and would just use the hex constant here (see the > comment at the top of pci_ids.h). The firmware populates the subsystem vendor and device ID for every device on the PCH with PCI_VENDOR_ID_CIRCUITCO and PCI_DEVICE_ID_CIRCUITCO_MINNOWBOARD, respectively. Currently I have only made changes to pch_gbe to make use of it, but there is the possibility of using this ID elsewhere. I don't currently have plans to do so however. So if it is preferable, I can leave PCI_VENDOR_ID_CIRCUITCO in pci_ids.h and use 0x0001 here for the subsystem device ID. -- Darren Hart Intel Open Source Technology Center Yocto Project - Technical Lead - Linux Kernel -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/