Hello,

This is a second version of my sort key cleanup series.  I Added
helper function for adding sort key and used unmap_ip() function for
printing symbol address as Jiri commented.  But didn't change name of
the sort keys to 'ip'.  If you really think I should change, I'm okay
to do it though.  I also cleaned up sort__has_sym and sort key eliding
code in this version.

You can get it from 'perf/sort-v4' branch on my tree at:

  git://git.kernel.org/pub/scm/linux/kernel/namhyung/linux-perf.git


Any comments are welcome, thanks.
Namhyung


Namhyung Kim (10):
  perf sort: Factor out common code in sort_dimension__add()
  perf sort: Separate out memory-specific sort keys
  perf sort: Add 'addr' sort key
  perf sort: Add 'addr_to/from' sort key
  perf sort: Update documentation for sort keys
  perf hists: Move column length setting code
  perf sort: Cleanup sort__has_sym setting
  perf top: Use sort__has_sym
  perf hist browser: Use sort__has_sym
  perf sort: Consolidate sort_entry__setup_elide()

 tools/perf/Documentation/perf-diff.txt   |   2 +-
 tools/perf/Documentation/perf-report.txt |   5 +-
 tools/perf/Documentation/perf-top.txt    |   2 +-
 tools/perf/builtin-diff.c                |   6 +-
 tools/perf/builtin-report.c              |  28 +----
 tools/perf/builtin-top.c                 |  19 +--
 tools/perf/ui/browsers/hists.c           |   9 +-
 tools/perf/util/hist.c                   |  17 +--
 tools/perf/util/hist.h                   |   5 +-
 tools/perf/util/sort.c                   | 201 +++++++++++++++++++++++++------
 tools/perf/util/sort.h                   |  25 ++--
 tools/perf/util/top.h                    |   1 -
 12 files changed, 218 insertions(+), 102 deletions(-)

-- 
1.7.11.7

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to