On Fri, Mar 15, 2013 at 9:23 PM, Kirill A. Shutemov <kirill.shute...@linux.intel.com> wrote: > Hillf Danton wrote: >> On Fri, Mar 15, 2013 at 1:50 AM, Kirill A. Shutemov >> <kirill.shute...@linux.intel.com> wrote: >> > + page_cache_get(page); >> > + spin_lock_irq(&mapping->tree_lock); >> > + page->mapping = mapping; >> > + page->index = offset; >> > + error = radix_tree_insert(&mapping->page_tree, offset, page); >> > + if (unlikely(error)) >> > + goto err; >> > + if (PageTransHuge(page)) { >> > + int i; >> > + for (i = 1; i < HPAGE_CACHE_NR; i++) { >> struct page *tail = page + i; to easy reader >> >> > + page_cache_get(page + i); >> s/page_cache_get/get_page_foll/ ? > > Why? > see follow_trans_huge_pmd() please. -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
- Re: [PATCHv2, RFC 23/30] thp: prepare zap_huge_pmd... Hillf Danton
- Re: [PATCHv2, RFC 23/30] thp: prepare zap_huge... Kirill A. Shutemov
- [PATCHv2, RFC 12/30] thp, mm: add event counters for hu... Kirill A. Shutemov
- [PATCHv2, RFC 20/30] ramfs: enable transparent huge pag... Kirill A. Shutemov
- [PATCHv2, RFC 17/30] thp: wait_split_huge_page(): seria... Kirill A. Shutemov
- [PATCHv2, RFC 05/30] thp, mm: avoid PageUnevictable on ... Kirill A. Shutemov
- [PATCHv2, RFC 10/30] thp, mm: locking tail page is a bu... Kirill A. Shutemov
- [PATCHv2, RFC 08/30] thp, mm: rewrite add_to_page_cache... Kirill A. Shutemov
- Re: [PATCHv2, RFC 08/30] thp, mm: rewrite add_to_p... Hillf Danton
- Re: [PATCHv2, RFC 08/30] thp, mm: rewrite add_... Kirill A. Shutemov
- Re: [PATCHv2, RFC 08/30] thp, mm: rewrite ... Hillf Danton
- Re: [PATCHv2, RFC 08/30] thp, mm: rewr... Kirill A. Shutemov
- Re: [PATCHv2, RFC 08/30] thp, mm:... Hillf Danton
- Re: [PATCHv2, RFC 08/30] thp,... Kirill A. Shutemov
- [PATCHv2, RFC 18/30] thp, mm: truncate support for tran... Kirill A. Shutemov
- [PATCHv2, RFC 06/30] thp, mm: basic defines for transpa... Kirill A. Shutemov
- [PATCHv2, RFC 29/30] thp: call __vma_adjust_trans_huge(... Kirill A. Shutemov
- [PATCHv2, RFC 03/30] mm: drop actor argument of do_gene... Kirill A. Shutemov
- Re: [PATCHv2, RFC 03/30] mm: drop actor argument o... Hillf Danton
- Re: [PATCHv2, RFC 03/30] mm: drop actor argument o... Hillf Danton
- Re: [PATCHv2, RFC 03/30] mm: drop actor argume... Kirill A. Shutemov