* Oleg Nesterov <o...@redhat.com> [2012-12-31 18:52:20]:

> Rename add_utask() into get_utask() and change it to allocate on
> demand to simplify the caller. Like get_xol_area() it will have
> more users.
> 
> Signed-off-by: Oleg Nesterov <o...@redhat.com>

Acked-by: Srikar Dronamraju <sri...@linux.vnet.ibm.com>

> ---
>  kernel/events/uprobes.c |   27 +++++++++------------------
>  1 files changed, 9 insertions(+), 18 deletions(-)
> 
> diff --git a/kernel/events/uprobes.c b/kernel/events/uprobes.c
> index ef81162..b09b3ba 100644
> --- a/kernel/events/uprobes.c
> +++ b/kernel/events/uprobes.c
> @@ -1290,23 +1290,18 @@ void uprobe_copy_process(struct task_struct *t)
>  }
> 
>  /*
> - * Allocate a uprobe_task object for the task.
> - * Called when the thread hits a breakpoint for the first time.
> + * Allocate a uprobe_task object for the task if if necessary.
> + * Called when the thread hits a breakpoint.
>   *
>   * Returns:
>   * - pointer to new uprobe_task on success
>   * - NULL otherwise
>   */
> -static struct uprobe_task *add_utask(void)
> +static struct uprobe_task *get_utask(void)
>  {
> -     struct uprobe_task *utask;
> -
> -     utask = kzalloc(sizeof *utask, GFP_KERNEL);
> -     if (unlikely(!utask))
> -             return NULL;
> -
> -     current->utask = utask;
> -     return utask;
> +     if (!current->utask)
> +             current->utask = kzalloc(sizeof(struct uprobe_task), 
> GFP_KERNEL);
> +     return current->utask;
>  }
> 
>  /* Prepare to single-step probed instruction out of line. */
> @@ -1505,13 +1500,9 @@ static void handle_swbp(struct pt_regs *regs)
>       if (unlikely(!test_bit(UPROBE_COPY_INSN, &uprobe->flags)))
>               goto out;
> 
> -     utask = current->utask;
> -     if (!utask) {
> -             utask = add_utask();
> -             /* Cannot allocate; re-execute the instruction. */
> -             if (!utask)
> -                     goto out;
> -     }
> +     utask = get_utask();
> +     if (!utask)
> +             goto out;       /* re-execute the instruction. */
> 
>       handler_chain(uprobe, regs);
>       if (can_skip_sstep(uprobe, regs))
> -- 
> 1.5.5.1
> 

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to