在 2024/8/12 19:29, Oleg Nesterov 写道:
> On 08/09, Liao Chang wrote:
>>
>> --- a/include/linux/uprobes.h
>> +++ b/include/linux/uprobes.h
>> @@ -75,6 +75,7 @@ struct uprobe_task {
>>  
>>      struct uprobe                   *active_uprobe;
>>      unsigned long                   xol_vaddr;
>> +    bool                            deny_signal;
> 
> Ack, but... I can't believe I am arguing with the naming ;)
> Can we have a better name for this flag?
> 
>       utask->signal_denied ?
>       utask->restore_sigpending ?

I prefer the name "signal_denied" as it more accurately reflects
what happened.

> 
> or just
> 
>       utask->sigpending ?
> 
> utask->deny_signal looks as if handle_singlestep/whatever should
> "deny" the pending signal cleared by uprobe_deny_signal(), while
> it fact it should restore TIF_SIGPENDING.

Make sense. I will change the name in v3.

> 
> Oleg.
> 
>>  
>>      struct return_instance          *return_instances;
>>      unsigned int                    depth;
>> diff --git a/kernel/events/uprobes.c b/kernel/events/uprobes.c
>> index 76a51a1f51e2..77934fbd1370 100644
>> --- a/kernel/events/uprobes.c
>> +++ b/kernel/events/uprobes.c
>> @@ -1979,6 +1979,7 @@ bool uprobe_deny_signal(void)
>>      WARN_ON_ONCE(utask->state != UTASK_SSTEP);
>>  
>>      if (task_sigpending(t)) {
>> +            utask->deny_signal = true;
>>              clear_tsk_thread_flag(t, TIF_SIGPENDING);
>>  
>>              if (__fatal_signal_pending(t) || 
>> arch_uprobe_xol_was_trapped(t)) {
>> @@ -2288,9 +2289,10 @@ static void handle_singlestep(struct uprobe_task 
>> *utask, struct pt_regs *regs)
>>      utask->state = UTASK_RUNNING;
>>      xol_free_insn_slot(current);
>>  
>> -    spin_lock_irq(&current->sighand->siglock);
>> -    recalc_sigpending(); /* see uprobe_deny_signal() */
>> -    spin_unlock_irq(&current->sighand->siglock);
>> +    if (utask->deny_signal) {
>> +            set_thread_flag(TIF_SIGPENDING);
>> +            utask->deny_signal = false;
>> +    }
>>  
>>      if (unlikely(err)) {
>>              uprobe_warn(current, "execute the probed insn, sending 
>> SIGILL.");
>> -- 
>> 2.34.1
>>
> 
> 

-- 
BR
Liao, Chang

Reply via email to