Don't use an O(nm) algorithm* and make it more readable by using a dict.

*Most obviously, it does a nested for-loop over the entire other config.
A bit more subtle, it calls .entries(), which constructs a set from the
list for _every_ outer iteration.

Signed-off-by: Daniel Latypov <dlaty...@google.com>
---
 tools/testing/kunit/kunit_config.py | 13 ++++++-------
 1 file changed, 6 insertions(+), 7 deletions(-)

diff --git a/tools/testing/kunit/kunit_config.py 
b/tools/testing/kunit/kunit_config.py
index 02ffc3a3e5dc..f1101075d458 100644
--- a/tools/testing/kunit/kunit_config.py
+++ b/tools/testing/kunit/kunit_config.py
@@ -40,15 +40,14 @@ class Kconfig(object):
                self._entries.append(entry)
 
        def is_subset_of(self, other: 'Kconfig') -> bool:
+               other_dict = {e.name: e.value for e in other.entries()}
                for a in self.entries():
-                       found = False
-                       for b in other.entries():
-                               if a.name != b.name:
+                       b = other_dict.get(a.name)
+                       if b is None:
+                               if a.value == 'n':
                                        continue
-                               if a.value != b.value:
-                                       return False
-                               found = True
-                       if a.value != 'n' and found == False:
+                               return False
+                       elif a.value != b:
                                return False
                return True
 

base-commit: c6f7e1510b872c281ff603a3108c084b6548d35c
-- 
2.29.2.576.ga3fc446d84-goog

Reply via email to