On Wed, Aug 29, 2007 at 08:07:10PM +0100, Christoph Hellwig wrote: > > * Switch from path_release_on_umount(nd) to pathput_on_umount(&nd->path). > > > > * Rename dput_path() to pathput_conditional(). > > The introduction of pathput is fine we me. The removal of path_release > doesn't make much sense. We have tons of invocations of exactly that > patter, and having keeping path_release for that makes a lot of sense.
After some private discussion on this I think I was overruled, so feel free to keep that change. Al also suggested to rename the things to path_get/path_put which makes sense. Any chance you could respin the series with the review comments addressed so that there is a chance to get it into 2.6.24? - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/