On 05/02/2019 09.05, Masahiro Yamada wrote: > On Mon, Feb 4, 2019 at 4:24 AM Rasmus Villemoes > <li...@rasmusvillemoes.dk> wrote: >> >> BUILD_BUG_ON() is a little annoying, since it cannot be used outside >> function scope. So one cannot put assertions about the sizeof() a >> struct next to the struct definition, but has to hide that in some >> more or less arbitrary function. >> >> Since gcc 4.6 (which is now also the required minimum), there is >> support for the C11 _Static_assert in all C modes, including gnu89. So >> add a simple wrapper for that. >> >> _Static_assert() requires a message argument, which is usually quite >> redundant (and I believe that bug got fixed at least in newer C++ >> standards), but we can easily work around that with a little macro >> magic, making it optional. >> >> For example, adding >> >> static_assert(sizeof(struct printf_spec) == 8); >> >> in vsprintf.c and modifying that struct to violate it, one gets >> >> ./include/linux/build_bug.h:78:41: error: static assertion failed: >> "sizeof(struct printf_spec) == 8" >> #define __static_assert(expr, msg, ...) _Static_assert(expr, "" msg "") >> >> godbolt.org suggests that _Static_assert() has been support by clang >> since at least 3.0.0. >> >> Signed-off-by: Rasmus Villemoes <li...@rasmusvillemoes.dk> >> --- >> include/linux/build_bug.h | 19 +++++++++++++++++++ >> 1 file changed, 19 insertions(+) >> >> diff --git a/include/linux/build_bug.h b/include/linux/build_bug.h >> index faeec7433aab..4bf9ba847b44 100644 >> --- a/include/linux/build_bug.h >> +++ b/include/linux/build_bug.h >> @@ -58,4 +58,23 @@ >> */ >> #define BUILD_BUG() BUILD_BUG_ON_MSG(1, "BUILD_BUG failed") >> >> +/** >> + * static_assert - check integer constant expression at build time >> + * >> + * static_assert() is a wrapper for the C11 _Static_assert, with a >> + * little macro magic to make the message optional (defaulting to the >> + * stringification of the tested expression). >> + * >> + * Contrary to BUILD_BUG_ON(), static_assert() can be used at global >> + * scope, but requires the expression to be an integer constant >> + * expression (i.e., it is not enough that __builtin_constant_p() is >> + * true for expr). >> + * >> + * Also note that BUILD_BUG_ON() fails the build if the condition is >> + * true, while static_assert() fails the build if the expression is >> + * false. >> + */ >> +#define static_assert(expr, ...) __static_assert(expr, ##__VA_ARGS__, #expr) >> +#define __static_assert(expr, msg, ...) _Static_assert(expr, "" msg "") > > What is the "" "" for?
Good point. It's a leftover from when I had a fallback-implementation of _Static_assert for gcc < 4.6, where I wanted to ensure that the second argument was a string literal, even if my fallback implementation ignored that argument. Now it's actually a little harmful, because foobar.c:5:34: error: expected string literal before ‘expected’ static_assert(sizeof(long) == 8, expected 64 bit machine); is better than foobar.c:4:34: error: expected ‘)’ before ‘expected’ static_assert(sizeof(long) == 8, expected 64 bit machine); > Bikeshed: > > There might be room for argument about > where this macro should go. > > Another possible place is <linux/compiler.h> > where compiletime_assert() is defined. I'd rather move compiletime_assert to build_bug.h, and rename it so that it becomes an implementation detail of BUILD_BUG. There are not that many direct users of compiletime_assert(), and I think we should standardize on fewer ways of achieving the same thing. static_assert() for checking ICEs, usable at any scope, and BUILD_BUG_* for checking that the optimizer is sufficiently smart. This would also be a step towards another cleanup I'd like to do: make build_bug.h not depend on compiler.h, because we already have a dependency in the other direction (ARRAY_SIZE using BUILD_BUG_ON_ZERO). Rasmus