Hi Steve, On 26/11/2018 19:06, Steven Sistare wrote: > [...] >> Mmm I was thinking we could abuse the wrap() and start at >> (fls(prev_span) + 1), but we're not guaranteed to have contiguous spans - >> the Arm Juno for instance has [0, 3, 4], [1, 2] as MC-level domains, so >> that goes down the drain. >> >> Another thing that has been trotting in my head would be some helper to >> create a cpumask from a sparsemask (some sort of sparsemask_span()), >> which would let us use the standard mask operators: >> >> ----->8----- >> struct cpumask *overload_span = sparsemask_span(overload_cpus) >> >> for_each_domain(this_cpu, sd) >> for_each_cpu_and(src_cpu, overload_span, sched_domain_span(sd)) >> <steal_from here> >> -----8>----- >> >> The cpumask could be part of the sparsemask struct to save us the >> allocation, and only updated when calling sparsemask_span(). > > I thought of providing something like this along with other sparsemask > utility functions, but I decided to be minimalist, and let others add > more functions if/when they become needed. > this_cpu_cpumask_var_ptr(select_idle_mask) > is a temporary that could be used as the destination of the conversion. > > Also, conversion adds cost, particularly on larger systems. When comparing a > cpumask and a sparsemask, it is more efficient to iterate over the smaller > set, and test for membership in the larger, such as in try_steal: > > for_each_cpu(src_cpu, cpu_smt_mask(dst_cpu)) { > if (sparsemask_test_elem(src_cpu, overload_cpus) > >>> To extend stealing across LLC, I would like to keep the per-LLC sparsemask, >>> but add to each SD a list of sparsemask pointers. The list nodes would be >>> private, but the sparsemask structs would be shared. Each list would >>> include >>> the masks that overlap the SD's members. The list would be a singleton at >>> the >>> core and LLC levels (same as the socket level for most processors), and >>> would >>> have multiple elements at the NUMA level. >> >> I see. As for misfit, creating asym_cpucapacity siblings of the sd_llc_*() >> functions seems a bit much - there'd be a lot of redundancy for basically >> just a single shared sparsemask, which is why I was rambling about moving >> things to root_domain. >> >> Having different locations where sparsemasks are stored is a bit of a >> pain which I'd like to avoid, but if it can't be unified I suppose we'll >> have to live with it. > > I don't follow. A per-LLC sparsemask representing misfits can be allocated > with > one more line in sd_llc_alloc, and you can steal across LLC using the list I > briefly described above. >
Ah yes, that would work. Thing is, I had excluded having the misfit masks being in the sd_llc_shareds, since from a logical standpoint they don't really belong there. With asymmetric CPU capacities we kind of disregard the cache landscape and focus on, well, CPU asymmetries. There's a few commits laying around that forgo some cache usage optimisations for asymmetric systems - this one comes to mind: 9c63e84db29b ("sched/core: Disable SD_PREFER_SIBLING on asymmetric CPU capacity domains") So in truth I was envisioning separate SD_ASYM_CPUCAPACITY-based sparsemasks, which is why I was rambling about SD_ASYM_CPUCAPACITY siblings of sd_llc_*()... *But* after I had a go at it, it looked to me like that was a lot of duplicated code. My root_domain suggestion stems from the fact that we only really need one single sparsemask for misfit stealing, and it provides a unique location to store the sparsemasks (and you mask them however you want when it comes to using them). Sadly I think that doesn't work as well for cfs_overload_cpus since you can't split a sparsemask's chunks over several NUMA nodes, so we'd be stuck with an allocation on a single node (but we already do that in some places, e.g. for nohz.idle_cpus_mask, so... Is it that bad?). > - Steve >