Hi, On Saturday, 30 June 2007 00:35, Pavel Machek wrote: > Hi! > > > > > ALIGN > > > > .align 4096 > > > > @@ -31,6 +46,11 @@ wakeup_code: > > > > movw %cs, %ax > > > > movw %ax, %ds # Make > > > > ds:0 point to wakeup_start > > > > movw %ax, %ss > > > > + > > > > + testl $1, beep_flags - wakeup_code > > > > + jz 1f > > > > + BEEP > > > > +1: > > > > > > Can we rename/reuse existing flag variable? > > > > Sorry, but I can't resist the opportunity to say "Send a patch!" :) > > > > Seriously, though, I'd prefer not to. If we rename that acpi video flags > > variable (I assume this is what you're thinking of), we only create cause > > for > > confusion. A variable should for debugging or for controlling quirks, not > > for > > both at the same time. > > Cause for confusion? We are currently using 2 bits of that variable, > and we want to add one more bit. I seriously doubt that can confuse > anyone.
Well, indeed it would be more elegant to rename the existing flags variable and use another bit out of it, but I personally don't think it's _that_ important. At least, I don't think we should block the patch because of that. BTW, has anyone confirmed that it works on i386? BTW2, Nigel, please fix the formats in s2ram_beep_show()/_store(), they cause gcc to spit ugly warnings on some architectures. Greetings, Rafael -- "Premature optimization is the root of all evil." - Donald Knuth - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/