On Fri, Feb 23, 2018 at 08:37:32PM +0800, Boqun Feng wrote:
> On Fri, Feb 23, 2018 at 12:55:20PM +0100, Peter Zijlstra wrote:
> > On Thu, Feb 22, 2018 at 03:08:51PM +0800, Boqun Feng wrote:
> > > @@ -1012,6 +1013,33 @@ static inline bool bfs_error(enum bfs_result res)
> > >   return res < 0;
> > >  }
> > >  
> > > +#define DEP_NN_BIT 0
> > > +#define DEP_RN_BIT 1
> > > +#define DEP_NR_BIT 2
> > > +#define DEP_RR_BIT 3
> > > +
> > > +#define DEP_NN_MASK (1U << (DEP_NN_BIT))
> > > +#define DEP_RN_MASK (1U << (DEP_RN_BIT))
> > > +#define DEP_NR_MASK (1U << (DEP_NR_BIT))
> > > +#define DEP_RR_MASK (1U << (DEP_RR_BIT))
> > > +
> > > +static inline unsigned int __calc_dep_bit(int prev, int next)
> > > +{
> > > + if (prev == 2 && next != 2)
> > > +         return DEP_RN_BIT;
> > > + if (prev != 2 && next == 2)
> > > +         return DEP_NR_BIT;
> > > + if (prev == 2 && next == 2)
> > > +         return DEP_RR_BIT;
> > > + else
> > > +         return DEP_NN_BIT;
> > > +}
> > > +
> > > +static inline unsigned int calc_dep(int prev, int next)
> > > +{
> > > + return 1U << __calc_dep_bit(prev, next);
> > > +}
> > > +
> > >  static enum bfs_result __bfs(struct lock_list *source_entry,
> > >                        void *data,
> > >                        int (*match)(struct lock_list *entry, void *data),
> > > @@ -1921,6 +1949,16 @@ check_prev_add(struct task_struct *curr, struct 
> > > held_lock *prev,
> > >           if (entry->class == hlock_class(next)) {
> > >                   if (distance == 1)
> > >                           entry->distance = 1;
> > > +                 entry->dep |= calc_dep(prev->read, next->read);
> > > +         }
> > > + }
> > > +
> > > + /* Also, update the reverse dependency in @next's ->locks_before list */
> > > + list_for_each_entry(entry, &hlock_class(next)->locks_before, entry) {
> > > +         if (entry->class == hlock_class(prev)) {
> > > +                 if (distance == 1)
> > > +                         entry->distance = 1;
> > > +                 entry->dep |= calc_dep(next->read, prev->read);
> > >                   return 1;
> > >           }
> > >   }
> > 
> > I think it all becomes simpler if you use only 2 bits. Such that:
> > 
> >   bit0 is the prev R (0) or N (1) value,
> >   bit1 is the next R (0) or N (1) value.
> > 
> > I think this should work because we don't care about the empty set
> > (currently 0000) and all the complexity in patch 5 is because we can
> > have R bits set when there's also N bits. The concequence of that is
> > that we cannot replace ! with ~ (which is what I kept doing).
> > 
> > But with only 2 bits, we only track the strongest relation in the set,
> > which is exactly what we appear to need.
> > 
> 
> But if we only have RN and NR, both bits will be set, we can not check
> whether we have NN or not. Consider we have:
> 
>       A -(RR)-> B
>       B -(NR)-> C and B -(RN)-> C
>       C -(RN)-> A
> 
> this is not a deadlock case, but with "two bits" approach, we can not
> differ this with:
> 
>       A -(RR)-> B
>       B -(NN)-> C
>       C -(RN)-> A
> 
> , which is a deadlock.
> 
> But maybe "three bits" (NR, RN and NN bits) approach works, that is if
> ->dep is 0, we indicates this is only RR, and is_rx() becomes:
> 
>       static inline bool is_rx(u8 dep)
>       {
>               return !(dep & (NR_MASK | NN_MASK));
>       }
> 
> and is_xr() becomes:
> 
>       static inline bool is_xr(u8 dep)
>       {
>               return !(dep & (RN_MASK | NN_MASK));
>       }
> 
> , with this I think your simplification with have_xr works, thanks!
> 

Ah! I see. Actually your very first approach works, except the
definitions of is_rx() and ir_xr() are wrong. In that approach, you
define
        
        static inline bool is_rx(u8 dep)
        {
                return !!(dep & (DEP_RR_MASK | DEP_RN_MASK);
        }

, which means "whether we have a R* dependency?". But in fact, what we
need to check is "whether we _only_ have R* dependencies?", if so and
have_xr is true, that means we could only have a -(*R)-> A -(R*)-> if we
pick the next dependency, and that means we should skip. So my new
definition above works, and I think we better name it as only_rx() to
avoid confusion? Ditto for is_xr().

I also reorder bit number for each kind of dependency, so that we have a
simple __calc_dep_bit(), see the following:

        /*
         * DEP_*_BIT in lock_list::dep
         *
         * For dependency @prev -> @next:
         *
         *   RR: both @prev and @next are recursive read locks, i.e. ->read == 
2.
         *   RN: @prev is recursive and @next is non-recursive.
         *   NR: @prev is a not recursive and @next is recursive.
         *   NN: both @prev and @next are non-recursive.
         * 
         * Note that we define the value of DEP_*_BITs so that:
         *      bit0 is prev->read != 2
         *      bit1 is next->read != 2
         */
        #define DEP_RR_BIT 0
        #define DEP_RN_BIT 1
        #define DEP_NR_BIT 2
        #define DEP_NN_BIT 3

        #define DEP_RR_MASK (1U << (DEP_RR_BIT))
        #define DEP_RN_MASK (1U << (DEP_RN_BIT))
        #define DEP_NR_MASK (1U << (DEP_NR_BIT))
        #define DEP_NN_MASK (1U << (DEP_NN_BIT))

        static inline unsigned int
        __calc_dep_bit(struct held_lock *prev, struct held_lock *next)
        {
                return (prev->read != 2) + ((next->read != 2) << 1)
        }

        static inline u8 calc_dep(struct held_lock *prev, struct held_lock 
*next)
        {
                return 1U << __calc_dep_bit(prev, next);
        }

        static inline bool only_rx(u8 dep)
        {
                return !(dep & (DEP_NR_MASK | DEP_NN_MASK));
        }

        static inline bool only_xr(u8 dep)
        {
                return !(dep & (DEP_NR_MASK | DEP_NN_MASK));
        }

Note that we actually don't need DEP_RR_BIT, but I leave it there for
implementation simplicity. With this, your check and set below works.

Thoughts?

Regards,
Boqun

> > 
> > 
> >     if (have_xr && is_rx(entry->dep))
> >             continue;
> > 
> >     entry->have_xr = is_xr(entry->dep);
> > 
> > 
> > Or did I mess that up somewhere?


Attachment: signature.asc
Description: PGP signature

Reply via email to