On Thu, Apr 06, 2017 at 07:50:58PM +0530, Laxman Dewangan wrote:
> Use macro DIV_ROUND_CLOSEST_ULL() for 64bit division to closet one

"closest"

Thierry

> instead of implementing the same locally. This increase readability.
> 
> Signed-off-by: Laxman Dewangan <ldewan...@nvidia.com>
> ---
> Changes from V1:
> None
> 
>  drivers/pwm/pwm-tegra.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/drivers/pwm/pwm-tegra.c b/drivers/pwm/pwm-tegra.c
> index e464784..0a688da 100644
> --- a/drivers/pwm/pwm-tegra.c
> +++ b/drivers/pwm/pwm-tegra.c
> @@ -85,8 +85,7 @@ static int tegra_pwm_config(struct pwm_chip *chip, struct 
> pwm_device *pwm,
>        * nearest integer during division.
>        */
>       c *= (1 << PWM_DUTY_WIDTH);
> -     c += period_ns / 2;
> -     do_div(c, period_ns);
> +     c = DIV_ROUND_CLOSEST_ULL(c, period_ns);
>  
>       val = (u32)c << PWM_DUTY_SHIFT;
>  
> -- 
> 2.1.4
> 

Attachment: signature.asc
Description: PGP signature

Reply via email to