Hi David,

On Sun, Mar 12, 2017 at 09:11:53AM +0000, David Howells wrote:
> Eric Biggers <ebigge...@gmail.com> wrote:
> 
> > +static int cp_statx(const struct kstat *stat, struct statx __user *buffer)
> > ...
> > +   struct statx tmp;
> 
> This function needs to be "noinline" as tmp is big.
> 
> > -   return statx_set_result(&stat, buffer);
> > +
> > +   return cp_statx(&stat, buffer);
> 
> Can you leave it as statx_set_result rather than renaming it to cp_statx?
> 
> David

I agree with using 'noinline'.

But I think the name "cp_statx()" is better because it's consistent with the
existing functions in the file:

        cp_old_stat()
        cp_new_stat()
        cp_new_stat64()

- Eric

Reply via email to