Eric Biggers <ebigge...@gmail.com> wrote:

> +static int cp_statx(const struct kstat *stat, struct statx __user *buffer)
> ...
> +     struct statx tmp;

This function needs to be "noinline" as tmp is big.

> -     return statx_set_result(&stat, buffer);
> +
> +     return cp_statx(&stat, buffer);

Can you leave it as statx_set_result rather than renaming it to cp_statx?

David

Reply via email to