On Jul 21 2016 or thereabouts, Javier Martinez Canillas wrote:
> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
> 
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
> 
> Signed-off-by: Javier Martinez Canillas <jav...@osg.samsung.com>
> 
> ---

Reviewed-by: Benjamin Tissoires <benjamin.tissoi...@redhat.com>

Cheers,
Benjamin

> 
> Changes in v2:
> - Post correct patch since v1 got mangled by the MTA.
> 
>  drivers/hid/hid-core.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/drivers/hid/hid-core.c b/drivers/hid/hid-core.c
> index 08f53c7fd513..386f31481c06 100644
> --- a/drivers/hid/hid-core.c
> +++ b/drivers/hid/hid-core.c
> @@ -2480,7 +2480,7 @@ static const struct hid_device_id hid_ignore_list[] = {
>       { HID_USB_DEVICE(USB_VENDOR_ID_PANJIT, 0x0004) },
>       { HID_USB_DEVICE(USB_VENDOR_ID_PHILIPS, 
> USB_DEVICE_ID_PHILIPS_IEEE802154_DONGLE) },
>       { HID_USB_DEVICE(USB_VENDOR_ID_POWERCOM, USB_DEVICE_ID_POWERCOM_UPS) },
> -#if defined(CONFIG_MOUSE_SYNAPTICS_USB) || 
> defined(CONFIG_MOUSE_SYNAPTICS_USB_MODULE)
> +#if IS_ENABLED(CONFIG_MOUSE_SYNAPTICS_USB)
>       { HID_USB_DEVICE(USB_VENDOR_ID_SYNAPTICS, USB_DEVICE_ID_SYNAPTICS_TP) },
>       { HID_USB_DEVICE(USB_VENDOR_ID_SYNAPTICS, 
> USB_DEVICE_ID_SYNAPTICS_INT_TP) },
>       { HID_USB_DEVICE(USB_VENDOR_ID_SYNAPTICS, USB_DEVICE_ID_SYNAPTICS_CPAD) 
> },
> -- 
> 2.5.5
> 

Reply via email to