On Sun, Jun 19, 2016 at 08:54:32PM -0700, Bin Gao wrote:
> > > +#define DRV_NAME "bxt_wcove_gpio"
> > 
> > Drop this.
> We have _TWO_ places using DRV_NAME(near the end of the file):
> static struct platform_driver wcove_gpio_driver = {
>        .driver = {
>                .name = DRV_NAME,
>        },
> 
> and
> 
> MODULE_ALIAS("platform:" DRV_NAME);
> 
> You are suggesting to replace DRV_NAME with bxt_wcove_gpio(but why?)
> or something else?

Do instead this:

        .driver = {
                .name ="bxt_wcove_gpio",
        },

and

MODULE_ALIAS("platform:bxt_wcove_gpio");

Reply via email to