On Fri, 22 Dec 2006, Christoph Hellwig wrote: > On Wed, Dec 20, 2006 at 04:46:51PM -0800, Andrew Morton wrote: > > On Sun, 17 Dec 2006 07:43:39 -0500 (EST) > > "Robert P. J. Day" <[EMAIL PROTECTED]> wrote: > > > > > as with ARRAY_SIZE(), there are a number of places (mercifully, far > > > fewer) that recode what could be done with the FIELD_SIZEOF() macro in > > > kernel.h. > > Who introduced FIELD_SIZEOF? The name is the wrong way around, it > should either be SIZEOF_FIELD if you want the SIZEOF part of > FIELD_SIZE if you want to follow the ARRAY_SIZE example/
that's the name as it *already* existed in kernel.h. however, since no one was actually using it yet, it's a piece of cake to give it a better name. either FIELD_SIZE or MEMBER_SIZE would work just fine. rday - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/