From: Heiko Carstens <[EMAIL PROTECTED]> [S390] uaccess_pt: add missing down_read() and convert to is_init().
Doesn't seem to be a good idea to duplicate code :) Signed-off-by: Heiko Carstens <[EMAIL PROTECTED]> Signed-off-by: Martin Schwidefsky <[EMAIL PROTECTED]> --- arch/s390/lib/uaccess_pt.c | 5 +++-- 1 files changed, 3 insertions(+), 2 deletions(-) diff -urpN linux-2.6/arch/s390/lib/uaccess_pt.c linux-2.6-patched/arch/s390/lib/uaccess_pt.c --- linux-2.6/arch/s390/lib/uaccess_pt.c 2006-12-08 15:52:19.000000000 +0100 +++ linux-2.6-patched/arch/s390/lib/uaccess_pt.c 2006-12-08 15:52:40.000000000 +0100 @@ -8,8 +8,8 @@ */ #include <linux/errno.h> -#include <asm/uaccess.h> #include <linux/mm.h> +#include <asm/uaccess.h> #include <asm/futex.h> static inline int __handle_fault(struct mm_struct *mm, unsigned long address, @@ -60,8 +60,9 @@ out: out_of_memory: up_read(&mm->mmap_sem); - if (current->pid == 1) { + if (is_init(current)) { yield(); + down_read(&mm->mmap_sem); goto survive; } printk("VM: killing process %s\n", current->comm); - To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/