(David, see the note at the end of this post) It's not that I want to split hairs; I want to get the new variable names right the first time. My apologies to any of you who are getting tired with this process. My current (and hopefully final) proposal is now this:
CURRENT NAME PROPOSED NAME ------------ ------------- top-system top-system top-title top-markup between-title markup-markup after-title markup-system between-system system-system before-title system-markup bottom-system system-bottom between-scores-system score-system I've realized one subtlety that should help decide the remaining debates. LilyPond has two types of titles, bookTitleMarkup (title, composer, etc.) and scoreTitleMarkup (piece and opus). The elements of bookTitleMarkup will only display if they are entered in a top-level \header block, so they cannot be considered part of a "score". The elements of scoreTitleMarkup can be entered in a \header block within a \score block, so they are obviously part of the score. Here's my rationale for the remaining debates: * * * * * * * * * * "between-scores-system-spacing" only applies to this case: 1) from last system of one score to first system of a new score, with no intervening top-level markup or scoreTitleMarkup. So calling this variable "score-score-spacing" is misleading because it does not apply when the new score has a scoreTitleMarkup. So now I favor "score-system-spacing". * * * * * * * * * * "after-title-spacing" applies to these cases: 1) from top-level markup to first system of a new score. 2) from bookTitleMarkup to first system of a new score (when scoreTitleMarkup is absent) 3) within a score, from scoreTitleMarkup to first system. IMO, within the proposed naming scheme, the only real choice for after-title-spacing is "markup-system-spacing", since "markup-score-spacing" is misleading since it does not apply to scores with a scoreTitleMarkup. * * * * * * * * * * "before-title-spacing" applies to these cases: 1) from last system in a score to top-level markup. 2) from last system of one score to scoreTitleMarkup of another score. Within the proposed naming scheme, the 2 choices for before-title-spacing are: system-markup-spacing score-markup-spacing Carl likes "score-markup-spacing" for at least 2 reasons: 1) the upper attachment point is always the end of a score. 2) "system-markup" suggests that it should work within a single score, and it doesn't. I've gone back and forth, but now I'm in favor of "system-markup-spacing" for the following reasons: 1) it complements "markup-system-spacing" which is easier to remember. 2) I disagree with Carl's #2 above since "markup" in a variable name only refers to top-level markups (and this will be made clear in the documentation). * * * * * * * * * * If you're okay with the latest proposal, or if you have additional arguments... let me know either way. David, I didn't mean to disregard your last suggestion: > spacing markup markup = 3cm > spacing score markup = ... It's just that it looks like a much bigger change, and unless someone chimes in with an endorsement and a feasible implementation strategy, I don't realistically see that happening before the next release. But if anyone here can do this, definitely chime in! Thanks. - Mark _______________________________________________ lilypond-devel mailing list lilypond-devel@gnu.org http://lists.gnu.org/mailman/listinfo/lilypond-devel