Very pretty slurs!

http://codereview.appspot.com/41099/diff/1021/59
File lily/bezier.cc (right):

http://codereview.appspot.com/41099/diff/1021/59#newcode275
Line 275: Bezier::subdivide (Real t, Bezier &left_part, Bezier
&right_part)
We only use references if they are const (for clarity), so please change
the arguments to pointers. Also, this function can be marked as const.

http://codereview.appspot.com/41099/diff/1021/59#newcode296
Line 296: Bezier::extract (Real t_min, Real t_max)
const here too

http://codereview.appspot.com/41099/diff/1021/59#newcode302
Line 302: bez2.control_[i] = control_[i];
bez2 = *this

http://codereview.appspot.com/41099/diff/1021/62
File lily/lookup.cc (right):

http://codereview.appspot.com/41099/diff/1021/62#newcode347
Line 347: SCM dash_details)
Since dash_details seems to just be a list of Reals, perhaps its better
to have a vector<Real> const& (with an empty vector to signify a solid
slur).

http://codereview.appspot.com/41099


_______________________________________________
lilypond-devel mailing list
lilypond-devel@gnu.org
http://lists.gnu.org/mailman/listinfo/lilypond-devel

Reply via email to