On Wednesday 17 June 2015 14:20:05 Pali Rohár wrote: > On Wednesday 17 June 2015 15:11:22 Joshua Joseph wrote: > > > And for handling problem with jabber resource now I got this idea: > > > > > > What about storing this? > > > * protocol > > > * account > > > * contact > > > * from_id > > > * to_id > > > * from_name > > > * to_name > > > > > > (from|to)_id will be full protcol *dependent* identifier, so jabber can > > > store full JID "user@host/resource" and account can represent your > > > local_id and contact your remote_id. > > > > > > But do not know now... Any idea? Make sense? At least it could be needed > > > to modify it to work with multi user group chat correctly... > > > > > > > > > Yes this makes sense. > > > > This could probably work for normal 1 vs 1 chat. For group chat it needs > fixing... or not ("contact" column as string identifier of group > chat/room)? Or maybe using separate table?? Come up with something... > > Anyway, proper SQL schema with good documentation is required. > > (And maybe invent better column name for from_id/to_id... if you want to > use _id suffix only for foreign keys) >
I think that above description should work fine for 1vs1 chat, irc chat, jabber MUC and skype group chat too... Every time in "protocol", "account" and "contact" columns will be stored Kopete::Protocol::pluginId(), Kopete::Acount::accountId() and Kopete::Contact::contactId() (of remote contact). In case of jabber MUC in "contact" will be stored MUC room name and in case of IRC just irc channel (IRC server e.g. freenode is stored as accountId()). And for Skype as contact will be stored some unique string (hash?) identifier of group chat session. Make sense? Or is there any problem? Or some change is needed? Think twice! Because you are person who will implement it! To prevent showing Skype unique string (stored in "contact") I would propose some "group_name" (or groupchat name, or invent better name) column where will be stored human readable name or description of chat. Maybe merging that group name with "is_group_chat" column could be possible (NULL group name means message is not from multi user chat). -- Pali Rohár pali.ro...@gmail.com _______________________________________________ kopete-devel mailing list kopete-devel@kde.org https://mail.kde.org/mailman/listinfo/kopete-devel