davidedmundson added inline comments. INLINE COMMENTS
> broulik wrote in ksortfilterproxymodel.h:44 > Did you try that `QRegularExpression` vs `QRegExp` thing? We did some research - Old Qt which we support doesn't convert JS to QRegularExpresssion - We don't want to write new code with QRegExp - I don't want to expose two properties and have QML doing ifdefs That doesn't help draw a conclusion. Though is there any benefit to creating a reg exp in JS space rather than here? > broulik wrote in ksortfilterproxymodel.h:58 > "but you can set it to null" - I think this thing needs a `RESET` method what do we gain doing that? You would use that with filterRowCallback = undefined; which is the same as now. I think RESET is only usable if you can't represent null in the passed data type. > broulik wrote in ksortfilterproxymodel.h:118 > Shouldn't this be an `int` and then you can drop all of that role names stuff? roleNames are always exported. Some people expose the roles as an enum, but not that many I certainly don't want to encourage magic numbers being used in QML. REPOSITORY R275 KItemModels REVISION DETAIL https://phabricator.kde.org/D25326 To: davidedmundson Cc: broulik, ahiemstra, mart, kde-frameworks-devel, LeGast00n, GB_2, michaelh, ngraham, bruns