bruns requested changes to this revision.
bruns added a comment.
This revision now requires changes to proceed.


  The change needs a proper commit message. A reference to the bug tracker is 
not sufficient.
  
  The commit message should (at least) include:
  
  - Description of the setup
    - The UDI of the relevant Solid device
    - The UDIs of its parents
    - Relevant Solid attributes of the devices, e.g. from solid-hardware details
  - Description of the actions done
  - Old and new behaviour
  
  Think of what happens if anyone changes the code later. The person must be 
able to replicate the setup, to check if any further changes break the code.

INLINE COMMENTS

> udisksmanager.cpp:222
> +    if (interfaces.contains(UD2_DBUS_INTERFACE_FILESYSTEM)
> +    ||  interfaces.contains(UD2_DBUS_INTERFACE_LOOP)) {
>          emit deviceRemoved(udi);

According to your description (which is hard to follow, because you refrain 
from writing complete sentences), what triggers here is the removal of the 
o.f.U2.FileSystem interface. There is no reasoning why the Loop interface 
matters here.

REPOSITORY
  R245 Solid

REVISION DETAIL
  https://phabricator.kde.org/D13869

To: anthonyfieroni, broulik, cfeck, dfaure, bruns
Cc: ngraham, bcooksley, bruns, kde-frameworks-devel, michaelh

Reply via email to