mlaurent requested changes to this revision. mlaurent added inline comments. This revision now requires changes to proceed.
INLINE COMMENTS > main.cpp:103 > + QStringLiteral("devices"), > + i18n("List devices "), > + QStringList{}, extra space at the end of i18n > main.cpp:112 > + QStringList names; > + for (const auto c : commands) { > + names.append(c.name); const auto &c ? > main.cpp:124 > + } > + return QStringList() ; > +} coding style: remove space after() > main.cpp:131 > + auto options = getOptions(c.name); > + QString optionStr = options.count() == 0 > + ? QString() options.count() == 0 => isEmpty() > main.cpp:135 > + > + auto str = QStringLiteral("%1 %2") > + .arg(QStringLiteral("%1%2%3") very hard to read it. Could you split in several QString so it will more easy to check it's if ok :) > main.cpp:203 > + const bool missingOnly = parser.isSet(QStringLiteral("missing-only")); > + const QString pattern = args.size() > 0 > + ? args.at(0) !isEmpty() REPOSITORY R293 Baloo REVISION DETAIL https://phabricator.kde.org/D11287 To: michaelh, #baloo, #frameworks, mlaurent Cc: mlaurent, ngraham, ashaposhnikov, michaelh, astippich, spoorun, nicolasfella, alexeymin