davidedmundson added a comment.

  Let's wait for the new kwaylandserver repo before pushing.
  
  But ++, looks good.

INLINE COMMENTS

> keyboard_shortcuts_inhibit_interface.cpp:21
> +
> +class KeyboardShortcutsInhibitorInterface::Private : public 
> QtWaylandServer::zwp_keyboard_shortcuts_inhibitor_v1
> +{

Q_DECL_PRIVATE

> keyboard_shortcuts_inhibit_interface.cpp:35
> +
> +KeyboardShortcutsInhibitorInterface::Private::Private(wl_resource *resource, 
> int id, SurfaceInterface *surface,
> +                                                      SeatInterface *seat,

It's not clear what resource this argument is referring to.

I think from reading the code it's the resource of the manager? At which point 
"parentResource" would be a better name.

Or separate client, id, version args.

REPOSITORY
  R127 KWayland

REVISION DETAIL
  https://phabricator.kde.org/D29231

To: bport, zzag, davidedmundson, apol
Cc: romangg, crossi, kde-frameworks-devel, LeGast00n, cblack, michaelh, 
ngraham, bruns

Reply via email to